System Requirements for Tricentis Tosca 13.3

To use all Tosca features and functions, local administrator rights are required for the installation. Write permission for the directory %TRICENTIS_PROJECTS% is required to operate Tricentis Tosca.

Hardware requirements for Tosca Commander

CPU

i5 Dual-Core 2.4Ghz

RAM

8 GB

Hard disk space

10 GB

Network

100 Mbit/s

Software requirements for Tosca Commander

Microsoft® .NET Framework Version 4.8 (Win 7, Win 8.1, Win 10)*

Microsoft Visual C++ 2010 Redistributable Package SP1 (x64/x86)*

Microsoft Visual C++ 2012 Redistributable Package Update 4 (x64/x86)*

Microsoft Visual C++ 2013 Redistributable Package (x86)*

Microsoft Visual C++ 2015 Redistributable Package Update 2 (x86)*

Microsoft Visual C++ 2015 Redistributable Package Update 3 (x64)*

*If not installed, this is automatically installed during Tricentis Tosca setup, however Tricentis recommends installing .NET Framework 4.8 before installing Tricentis Tosca.

Supported desktop operating systems

Win 7

Win 8.1

Win 10

32-bit systems*

**

64-bit systems (recommended)

**

*Minimum requirement. You may experience degraded Tosca performance due to hardware limitations on 32-bit systems compared to 64-bit systems.
**Anniversary Update or Fall Creators Update

Supported databases for multiuser mode, LDAP integration and test data management

Win 7

Win 8.1

Win 10

Microsoft® SQL Server 2012 (Editions: Standard, Enterprise, Developer, Express*)

Microsoft® SQL Server 2014 (Editions: Standard, Enterprise, Developer, Express*)

Microsoft® SQL Server 2016 (Editions: Standard, Enterprise, Developer, Express*)

Microsoft® SQL Server 2017 (Editions: Standard, Enterprise, Developer, Express*)

Oracle 11g, 12c and 18c

IBM DB2 v.10.x and v.11.1

*Limited support for the Express Edition.

Supported server operating systems

Windows Server 2016 (x64)

Tosca TBox

Engines

Compatibility

Win 7

Win 8.1

Win 10

AnyUI Engine 3.0

 


API Engine 3.0

Apache Active MQ Client: broker version 4.x or later




Apache Kafka version 2.1.0

HTTP(s) version 1.1

IBM MQ Client 9.1.0.4 or later

Oracle WebLogic version 12c

Rabbit MQ version 2.0 or later

TIBCO EMS Client: broker version 8.2 or later

DotNet Engine 3.0

Microsoft® .NET Framework Version 4.6


Microsoft® .NET Framework Version 4.7


Microsoft® .NET Framework Version 4.8


Excel Engine 3.0

Microsoft Excel 2007 or higher


HOST Engine 3.0

Supported emulators

AttachMate

Aviva

BlueZone

HostExplorer

InfoConnect

PersonalComm

Rumba

Java Engine 3.0

Oracle Java Version 1.8.x (Java 8)


Oracle Java Version 11


OpenJDK Version 11


JSON Engine 3.0

 

Mail Engine 3.0

Mail server capable of using SMTP, IMAP, EWS, and POP3 protocols

 

Mobile Engine 3.0

Appium Server Version 1.16.0

Android™ Version 5.0 up to 10.0

iOS Version 10.0 up to 13.1
Xcode Version 10.2 and 11.1. Tricentis recommends to use a version supported by Homebrew

Tricentis recommends to use Xcode 10.2 for devices with iOS 12.3 and Xcode 11.1 for devices with iOS 13.1

Mac device with Mac OS Version 10.13.6 or later and with Java Runtime Environment 1.8 or OpenJDK 1.8

PDF Engine 3.0

.Net Framework 4.6 (or higher)

Salesforce Engine 3.0

 

Supported Salesforce versions

Salesforce Lightning Experience
Salesforce Classic

SAP Engine 3.0

SAP GUI (ERP)

Version 7.3
Version 7.4
Version 7.5
Version 7.6










SAP Fiori Extension

 

See the XBrowser Engine 3.0 requirements

SAPUI5 Version 1.38

SAPUI5 Version 1.52

SAPUI5 Version 1.60

SAPUI5 Version 1.71

SAP Modern Applications

SAP SuccessFactors version 2017 and higher

SAP Hybris C4C version 2017 and higher

SAP Netweaver Extension

See the XBrowser Engine 3.0 requirements

SAP Business Client Version 6.0 patch 17

SAP Business Client Version 6.5 patch 17

SAP Business Client Version 7.0

Siebel Open UI Extension

See the XBrowser Engine 3.0 requirements

Siebel Open UI Version 8.2.2.4 and 15.0.0.0

UIA Engine 3.0

 

XBrowser Engine 3.0

Microsoft® Internet Explorer Version

9
10
11







Mozilla Firefox Version

60.9 ESR

68.8 ESR







Google Chrome Version

75 to 83




Microsoft Edge Version

38 to 81

Safari Version 13 (via WebDriver)

Chromium Version 65-70

XML Engine 3.0

 

Tosca Classic Engines

Software requirement for all Tosca Classic Engines

Microsoft® .NET Framework Version 3.5 (Win 7, Win 8.1, Win 10)

Engine

Compatibility

Win 7

Win 8.1

Win 10

Database

Databases via ODBC connection

Oracle 11g Express Edition,
MS SQL Server 2005, 2012
IBM DB2 v9.1







Delphi

Version 2007
Version 2009
Version 2010
Version XE2
Version 10 Seattle
Version XE6



















DotNet

Microsoft® .NET Framework (32 and 64-bit applications)

Version 4.0
Version 4.5





Excel

Microsoft® Excel
2007 (32-bit)
2010 (32- and 64-bit)
2013 (32-bit)










Flash

Flash Player Version 16.0.0.296




Microsoft® Windows Internet Explorer Version 8.0

ActionScript Version 3

Gupta

Version 2.1
Version 3.0
Version 5.1
Version 5.2
Version 6.0













HOST

 

Supported Terminal Emulators:

Host Explorer, IBM Perscom, Host on demand, RUMBA

HTML

Microsoft® Windows Internet Explorer

 

Version 7.0 (32-bit)
Version 8.0 (32 and 64-bit)
Version 9.0 (32 and 64-bit)
Version 10.0 (32-bit)
Version 11 (32-bit)













Java

Java Runtime Environment

Version 6u51 (32 and 64-bit)
Version 7u80 (32 and 64-bit)
Version 8u91 (32 and 64-bit)







SWT

Eclipse 3.3.1
Eclipse 3.5.1




FX

Embedded in Swing Container
(A customization is required to be able to steer controls.)

Outlook

Microsoft® Outlook 2007 (32-bit)
Microsoft® Outlook 2010 (32-bit)
Microsoft® Outlook 2013 (32-bit)







Powerbuilder

Version 8.0
Version 11.5
Version 11.51
Version 12.0
Version 12.5
Version 12.6
Version 2017



















SAP

SAP GUI (ERP)

Version 6.2.0 (PL 44)
Version 6.4 (PL 26-32)
Version 7.1 (PL 13)
Version 7.2 (PL 4)
Version 7.3
Version 7.4
















Siebel

Oracle Siebel

Version 7.8
Version 8.0.0.7
Version 8.1







Microsoft® Windows Internet Explorer

Version 7.0 (32-bit)
Version 8.0 (32-bit)




Textstream

 

UIA

 

Microsoft® .NET Framework

Version 4.0
Version 4.5




VB

Visual Basic 6.0

WPF

 

Microsoft® .NET Framework

Version 3.5 (32-bit)
Version 4.0 (32- and 64-bit)
Version 4.5 (32- and 64-bit)









WPF Powerbuilder Controls

Microsoft® .NET Framework (32-bit)

Version 3.5

Powerbuilder .NET Runtime

Version 12.1

Tosca Extensions

API Scan

API Scan Standalone

Microsoft® .NET Framework Version 4.7.1

Tosca Data Integrity

Tosca DI - Hardware requirements

CPU

i5 Dual-Core 2.4Ghz

RAM

8 GB (recommended: 16 GB or more)

Hard disk space

200 GB (to store DB extract and log files)

Network

1Gbit/s between DWH and Tosca Commander

Tosca DI - Software requirements

Tricentis Tosca

Version 13.3

Recommended screen resolution for Tosca DI Wizards

1600x900 or higher

Tosca Continuous Integration

Tosca Continuous Integration - ToscaCIJavaClient

Java Runtime Environment or OpenJDK

Version 8

Tricentis Tosca (local execution)

Version 13.3

Exploratory Testing Agent

Exploratory Testing Agent

Microsoft® .NET Framework Version 4.8

Supported operating systems

Win 7

Win 8.1

Win 10

32-bit systems*

64-bit systems (recommended)

*Minimum requirement. You may experience degraded performance on 32-bit systems due to hardware restrictions.

Tosca SAP Solution Manager Integration

Tosca SAP Solution Manager Integration

SAP Connector for Microsoft .NET 3.0 for .NET Framework 4 or higher

SAP Solution Manager

Version 7.2

Tricentis Tosca

Version 13.3

Tosca Distribution Agent

Hardware requirements for Tosca Distribution Agent

CPU

i5 Dual-Core 2.4 GHz

RAM

8 GB

Hard disk space

10 GB

Network

100 Mbit/s

Software requirements for Tosca Distribution Agent

Microsoft® .NET Framework

4.8

Tricentis Tosca

Version 13.3

Supported operating systems

Win 7

Win 8.1

Win 10

32-bit systems

64-bit systems (recommended)